Page 2 of 2 <12
Topic Options
#87540 - 2002-09-09 01:56 PM Re: Kixforms: Version 2.0.3
Shawn Administrator Offline
Administrator
*****

Registered: 1999-08-13
Posts: 8611
Jooel,

v2.0.3 should have that functionality, just tried this script and seems to work:

code:
Break On

$Form = CreateObject("Kixtart.Form")
$Form.FontSize = 12

$link = $form.hyperlink("Old HyperLink Caption")
$link.size = 200,30
$link.center
$link.caption = "New HyperLink Caption"

$Form.Center
$Form.Show
$List.SetFocus

While $Form.Visible
$=Execute($Form.DoEvents)
Loop

Exit 1


Top
#87541 - 2002-09-09 02:06 PM Re: Kixforms: Version 2.0.3
Lonkero Administrator Offline
KiX Master Guru
*****

Registered: 2001-06-05
Posts: 22344
Loc: OK
yeah...

sorry, but you had the form hidden.

I tried with:
code:
Break On

$Form = CreateObject("Kixtart.Form")
$Form.FontSize = 12

$t = $Form.hyperlink("The KiXtart Bulletin Board")
$t.width = 400
$t.height=200
$t.Center
$b = $Form.commandbutton("click me")
$b.onclick="$$t.caption='test'"


$t.Value = "http://www.kixtart.org"

$Form.Center
$Form.Show

While $Form.Visible
$=Execute($Form.DoEvents)
Loop

and after clicking the button the link wasn't link anymore.
_________________________
!

download KiXnet

Top
#87542 - 2002-09-09 02:13 PM Re: Kixforms: Version 2.0.3
Shawn Administrator Offline
Administrator
*****

Registered: 1999-08-13
Posts: 8611
yap - your right - the Caption gets changed but its not being refreshed (if you "wipe" another window over top of the form, you will see that change). The refresh property doesn't work (this needs to be fixed too), but if you "reshow" the hyperlink - it works, example:

code:
$b.onclick="$$t.caption='test' $$t.show"

Will fix all this in 2.0.4

-Shawn

Top
#87543 - 2002-09-09 02:15 PM Re: Kixforms: Version 2.0.3
Lonkero Administrator Offline
KiX Master Guru
*****

Registered: 2001-06-05
Posts: 22344
Loc: OK
thanks.
thought I was getting paranoid or something...
_________________________
!

download KiXnet

Top
#87544 - 2002-09-09 03:24 PM Re: Kixforms: Version 2.0.3
Lonkero Administrator Offline
KiX Master Guru
*****

Registered: 2001-06-05
Posts: 22344
Loc: OK
heh...
did not get it to work... don't know why but on bbchecker it says after:
$msg.caption="loading elements..."
$show ="my message"
$msg.caption=$show
$msg.show
? $msg.caption

just:
"loading elements..."

putting the alpha online on my server and leaving the topic for tonight...

would be nice to get it work. what is the estimated release week of 2.0.4?

{edit}
somehow it seems to work on the form but display wrong at the console...

[ 09. September 2002, 15:30: Message edited by: Lonkero ]
_________________________
!

download KiXnet

Top
Page 2 of 2 <12


Moderator:  Shawn, ShaneEP, Ruud van Velsen, Arend_, Jochen, Radimus, Glenn Barnas, Allen, Mart 
Hop to:
Shout Box

Who's Online
0 registered and 353 anonymous users online.
Newest Members
Praveer, Ollero, rayyo, Foxlicht, DonChild
17742 Registered Users

Generated in 0.037 seconds in which 0.015 seconds were spent on a total of 13 queries. Zlib compression enabled.

Search the board with:
superb Board Search
or try with google:
Google
Web kixtart.org