Page 1 of 1 1
Topic Options
#29791 - 2002-09-27 02:48 AM UserGetLocalGroups failed error
Chris Jorgan Offline
Fresh Scripter

Registered: 2002-08-29
Posts: 10
Loc: Japan
HELP!!!

I've written a script which used IF INGROUP to assign drive mappings - it is working for most people, however some users are getting a system registry error and the following even is logged on the local machine

"The description for Event ID ( 2221 ) in Source ( KIXTART ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. The following information is part of the event: UserGetInfo failed Error : The user name could not be found. (0x8ad/2221)."

and

"The description for Event ID ( 1332 ) in Source ( KIXTART ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. The following information is part of the event: GetPrimaryGroup failed Error : No mapping between account names and security IDs was done. (0x534/1332)."

Please note there are two other associated events too - but they basically say the same thing....

I have checked the user is a member of the group - that the group name is valid - and that they have relogged in since adding them to the group - any ideas? The funny thing is, the drives still map properly, but I would like to eliminate the errors in event viewer if possible. Any help would be tremendously appreciated.

Thanks
_________________________
'I have often regretted my speech, never my silence.' Xenocrates (396-314 BC) Chris Jorgan

Top
#29792 - 2002-09-27 03:02 AM Re: UserGetLocalGroups failed error
Les Offline
KiX Master
*****

Registered: 2001-06-11
Posts: 12734
Loc: fortfrances.on.ca
I would look at network properties. Perhaps extra protocols or binding (provider) order differences.
_________________________
Give a man a fish and he will be back for more. Slap him with a fish and he will go away forever.

Top
#29793 - 2002-09-30 03:07 AM Re: UserGetLocalGroups failed error
Chris Jorgan Offline
Fresh Scripter

Registered: 2002-08-29
Posts: 10
Loc: Japan
Thanks for the reply. Unfortunately, I don't believe that to be the problem as we only use the TCP/IP protocol. What exactly did you mean by binding differences. I located the bindings tab and didn't notice anything out of the normal. Does anyone else receive errors from drive mappings out there? Something I noticed is that I have to mention the domain name in my script when mapping drives such as:
If Ingroup ("Domainnamehere\Domain Users")
Use K: "File-Server\Folder"
Endif

If I do not add the domain name when mentioning global groups, the script errors out and the drives are not mapped. So it really becomes a unique problem since now the drives are being mapped (with domain name), the network global groups are recognized, but the error messages still appear in event viewer.
_________________________
'I have often regretted my speech, never my silence.' Xenocrates (396-314 BC) Chris Jorgan

Top
#29794 - 2002-09-30 03:34 AM Re: UserGetLocalGroups failed error
Lonkero Administrator Offline
KiX Master Guru
*****

Registered: 2001-06-05
Posts: 22346
Loc: OK
so, what is the client range? w2k,xp...?
kixtart version?
kixtart rpc running?
domain is nt or AD?
_________________________
!

download KiXnet

Top
#29795 - 2002-10-26 06:03 PM Re: UserGetLocalGroups failed error
Jean-Claude Offline
Fresh Scripter

Registered: 2002-10-26
Posts: 6
Loc: Dallas, Tx
Your not alone. I have seen this error as well.
Did you ever find a solution? I am about to try the 4.11 version (I was running 4.10 -- I think it's 4.10 anyway)

Top
#29796 - 2002-10-26 06:30 PM Re: UserGetLocalGroups failed error
Sealeopard Offline
KiX Master
*****

Registered: 2001-04-25
Posts: 11165
Loc: Boston, MA, USA
What do the following macros return:

@USERID
@WUSERID
@PRIMARYGROUP
@DOMAIN
@LDOMAIN
@COMMENT
@FULLNAME
@LANROOT
@LM
@LSERVER
@PRIV
@RSERVER
@SID

What operating systemns are affected? If Window s9x is affected has the KiXtart RPC service installed and started on all domain controllers?

Is it an Active Directory or Windows NT domain?
_________________________
There are two types of vessels, submarines and targets.

Top
#29797 - 2002-10-26 06:37 PM Re: UserGetLocalGroups failed error
Les Offline
KiX Master
*****

Registered: 2001-06-11
Posts: 12734
Loc: fortfrances.on.ca
Jens,
Jean-Claude is digging up all these corpses. It is difficult to understand his situation since you would have to follow his trail of carnage.
_________________________
Give a man a fish and he will be back for more. Slap him with a fish and he will go away forever.

Top
#29798 - 2002-10-26 06:49 PM Re: UserGetLocalGroups failed error
Les Offline
KiX Master
*****

Registered: 2001-06-11
Posts: 12734
Loc: fortfrances.on.ca
Jean-Claude,
Please familiarize yourself with board etiquette.

Topic: ABC's of KiXtart board etiquette and message to new forum users

What you are doing by digging up dead threads is the same as cross-posting and frowned upon. If the originators didn't bother to reply with a resolution, it is unlikely they are monitoring the thread. You could always try to PM them instead.
_________________________
Give a man a fish and he will be back for more. Slap him with a fish and he will go away forever.

Top
#29799 - 2002-10-27 12:57 AM Re: UserGetLocalGroups failed error
Howard Bullock Offline
KiX Supporter
*****

Registered: 2000-09-15
Posts: 5809
Loc: Harrisburg, PA USA
I have only seen these errors on NT computers where they are trying to resolve an foreign SID but could not because the workstation secure channel or the domain trust has failed. This can also happen when you try to reference an account from an untrusted SAM database.

Is the error happening consitently on on a particular computer(s) or does the problem follow the account?
_________________________
Home page: http://www.kixhelp.com/hb/

Top
#29800 - 2002-10-27 04:02 AM Re: UserGetLocalGroups failed error
Howard Bullock Offline
KiX Supporter
*****

Registered: 2000-09-15
Posts: 5809
Loc: Harrisburg, PA USA
Are you by chance using INGROUP to reference a Domain1\Group where the Domain1 is not the same domain as the @Ldomain (the domain to which the user logged on)? If this is the case, you will have to reference \\ServerName\Group instead.
_________________________
Home page: http://www.kixhelp.com/hb/

Top
Page 1 of 1 1


Moderator:  Jochen, Allen, Radimus, Glenn Barnas, ShaneEP, Ruud van Velsen, Arend_, Mart 
Hop to:
Shout Box

Who's Online
0 registered and 879 anonymous users online.
Newest Members
Viginette, ManuvdWielNL, Sir_Barrington, batdk82, StuTheCoder
17888 Registered Users

Generated in 0.06 seconds in which 0.024 seconds were spent on a total of 12 queries. Zlib compression enabled.

Search the board with:
superb Board Search
or try with google:
Google
Web kixtart.org