#20915 - 2002-04-30 05:27 PM
Login script doesntgive user's home drive mapping
|
Anonymous
Anonymous
Unregistered
|
We have a user running windows'95 and logs on to the NT domain. Kixstart executes when she logs in but doesn't give her home drive mapping. Any help is appreciated.
|
|
Top
|
|
|
|
#20916 - 2002-04-30 05:27 PM
Re: Login script doesntgive user's home drive mapping
|
Howard Bullock
KiX Supporter
   
Registered: 2000-09-15
Posts: 5809
Loc: Harrisburg, PA USA
|
Please post your code that maps the home drive.
|
|
Top
|
|
|
|
#20917 - 2002-04-30 05:39 PM
Re: Login script doesntgive user's home drive mapping
|
Anonymous
Anonymous
Unregistered
|
I get the same error - it's intermittent, here is the code. It works on some, on the ones that it doesn't, none of my if ingroup statements work. Some test ids work on some machines that don't I'm also posing a log file from a problem machine.
code
; ; Home Directory ; If @HOMESHR $Share = @HOMESHR $Letter = "V:" ?"Connecting "$Letter" to "$Share Use $Letter $Share ENDIF
Logfile
2002/04/30 11:32:48 - Failed to determine logonserver Error : The network path was not found. (0x35/53) 2002/04/30 11:32:48 - Error occured during retrieval of remote network information Error : (0x83a/2106) 2002/04/30 11:32:48 - Failed to locate/connect to a KXRPC server Error : The network path was not found. (0x35/53)
|
|
Top
|
|
|
|
#20918 - 2002-04-30 05:42 PM
Re: Login script doesntgive user's home drive mapping
|
Anonymous
Anonymous
Unregistered
|
The funny thing is that I can logon as a different user to this same box, and get all of my drives.
|
|
Top
|
|
|
|
#20919 - 2002-04-30 08:33 PM
Re: Login script doesntgive user's home drive mapping
|
BrianTX
Korg Regular
Registered: 2002-04-01
Posts: 895
|
So, if you run the script under the userid AFTER logging on, does it work? Try using:
code:
IF "@HOMESHR" <> "" USE V: @HOMESHR ENDIF
try this first by making a simple .kix file with just that line and running it locally on the PC (not in the logon script). If it doesn't work, try typing "NET USE V: /HOME" from a command prompt. If that works, then try the script again. You could also use @error to retrieve errors if you're not getting a drive mapping.
In my experience (to date), the most common causes of users not getting their drive mappings are that:
1. They don't have appropriate permissions to their home share or it doesn't exist. 2. Their home share isn't listed in user manager. 3. Their user profile has cached their username or password (in Windows 95 this has everything to do with .pwl files. Deleting the .pwl files often works.)
Brian
P.S. If you want to turn off password caching (a security risk) on Windows 95, try something like this:
code:
;*** REMOVE PASSWORD CACHING *** :PASSCACHE $OK=WRITEVALUE("HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Network","DisablePwdCaching","1","REG_DWORD") DEL "%WINDIR%\*.PWL" RETURN
Sure, users may complain about having to enter in passwords more frequently, but any joe blow off the street can hack a .pwl file and get network passwords, etc.
|
|
Top
|
|
|
|
#20920 - 2002-05-20 05:24 PM
Re: Login script doesntgive user's home drive mapping
|
MCA
KiX Supporter
   
Registered: 2000-04-28
Posts: 5152
Loc: Netherlands, EU
|
Dear,
Solved?
It is always very good to make required USE setting bulletproof.
It is possible to using also available homedrv & homeshr values, which values can be set by users profiles.
without settings the call can be: net use U: \\server\@userid$
code:
IF (len(@homedrv) <> 0) AND (len(@homeshr) <> 0) USE @homedrv /delete USE @homedrv "@homeshr" ELSE IF (len(@homeshr) <> 0) USE U: /delete USE U: "@homeshr" ELSE USE U: /delete USE U: "\\server\@userid$$" ENDIF ENDIF
greetings.
|
|
Top
|
|
|
|
#20922 - 2003-01-20 01:27 PM
Re: Login script doesntgive user's home drive mapping
|
Lesmondo
Fresh Scripter
Registered: 2002-11-12
Posts: 5
Loc: Scotia
|
I have a similar problem with Windows 95 Clients. If the length of the username is truncated to less than 17 characters, then the USE statement works fine. This may or may not depend on the server name length too but I haven't checked that. In my case the server is called DAN_SERVER. I haven't installed KXRPC service. Will this solve this issue? It would be great to get a solution otherwise I have to check for length of username across all the users (lots of them).
|
|
Top
|
|
|
|
Moderator: Jochen, Allen, Radimus, Glenn Barnas, ShaneEP, Ruud van Velsen, Arend_, Mart
|
0 registered
and 879 anonymous users online.
|
|
|